2025. 3. 29. 23:46ㆍCS/CCNA
VLANs(Part 3)
ROAS
Methods of configuring native VLAN on router:
- Use command encapsulation dot1q vlan-id native on the router subinterface
- Configure IP address for the native VLAN on the router's physical interface (encapsulation... cmd not nessary)
-> router was usded as the PC's gateway
Layer3(Multilayer) switches:
-> capable of both switching and routing
-> Can assign IP addresses to its interfaces (like router)
-> Can create virtual interfaces for each VLAN, assign IP address
-> Can configure routes on it (like router)
-> used for inter-VLAN routing
SVI (Switch Virtual Interfaces):
-> virtual interfaces you can assign IP in multilayer switch
-> Configure ecah PC to use SVI as their gateway address
-> Send traffic to different subnets/VLANs, PC will send traffic to the switch and switch routes it
-> when it configured, shutdown is default
Inter-VLAN Routing via SVI:
1) VLAN must exist on switch
2) switch must have at least one access port or trunk port allows VLAN up/up state
3) VLAN must not be shut down
4) SVI must not be shut down
//CLI
## Inter -VLAN Routing via SVI
// Router
R1(config)#no interface g0/0.10
##deletes subinterface (still remains if brief)
R1(config)#default interface g0/0
##resets G0/0 to default
R1(config)#interface g0/0
##enters g0/0 config mode
R1(config-if)#ip address 192.168.1.62[ip-ads] 255.255.255.192[sn mask]
// Switch
SW2(config)#default interface g0/1
## resets g0/1 (used as trunk port perviously)
SW2(config)#ip routing
##enables L3 routing on switch
SW2(config)#interface g0/1
SW2(config-if)#no switchport
## Changes if from L2 switch port to L3 routed port
SW2(config-if)#ip address 192.168.1.93[ip-ads] 255.255.255.252[sn mask]
## IP adrs assigned to it like as router interface
//default route pointing to R1 (SW2 > R1)
SW2(config-if)#exit
SW2(config)#ip route 0.0.0.0[dstin NW] 0.0.0.0[subnet] 192.168.1.194[next hop]
## 어떤 네트워크로 가든 192.168.1.194 에 넘겨라 (config default route)
SW2#show interfaces status
## will show G0/1 Vlan 'routed'
//SVI config
SW2(config)#interface vlan10
SW2(config-if)#ip address 192.168.1.62[ip-adrs] 255.255.255.192[subnet]
SW2(config-if)#no shutdown
## SVIs are shutdown default
Acronyms:
- SVI : Switch Virtual Interface
'CS > CCNA' 카테고리의 다른 글
CCNA 200-301 Exam Topic (0) | 2025.04.01 |
---|---|
<Jeremy's IT Lab> Day19: DPT, VTP (0) | 2025.03.30 |
<Jeremy's IT Lab> Day17: VLANs(Part 2) (0) | 2025.03.28 |
<Jeremy's IT Lab> Day16: VLANs(Part 1) (0) | 2025.03.27 |
<Jeremy's IT Lab> Day15: Subnetting(Part3) (0) | 2025.03.26 |